PDA

View Full Version : trans linkage problems



Joe Copsetta
10-12-2000, 03:41 AM
Hey all

Having trouble with the linkage on my 1965 Chevy Van. 3 speed on the column. The piece that connected the linkage rod to the trans cracked in half. Need to find this part. Before it cracked, it would always pop out of 3rd. I guess this is the reason why but not sure. There might be trouble in the trasmission. I don't know. Is this a common problem in these vans?

sambowie
10-12-2000, 02:46 PM
On my 66 chevy van, going from 1st to 2nd
it would stick, you have to slide up in reverse then to 2nd real quick, so youre not the only one with shift linkage problems on these old vans.

good luck

Vanner68
10-12-2000, 07:56 PM
That part may be hard to find, so save the pieces and get them welded up. Oh, and grease everything that moves!

vannman67
10-13-2000, 06:23 PM
I've got shifter linkage off my 67. Don't know if it's the same or not, but you're welcome to it. drop me an e-mail if you're interested. I upgraded to a B&M megashifter. still trying to work out the bugs, but it should work great.

Bryan

painterchris
10-13-2000, 11:42 PM
The linkage from a 67 is probably NOT the same. Read my reply to one of your other posts. You must know what transmission you have to be sure that you get the right linkage. Chevy used several different transmissions in these vans over the years and they each have unique linkage pieces. And, if a previous owner swapped out the tranny, you may have some custom pieces in there.
LAter,
Andy.